Skip to Content

Required Zoom Updates

You may be as tired of Zoom as we are. Nevertheless, there are 2 important updates you may need to know about.

Required Version Update

After May 30, you will be required to have version 5.0 or higher to connect to a Zoom meeting.

Zoom usually updates itself automatically. It’s likely that your version is already on 5.0! If not, you’ll be locked out of meetings come June 1.

Use our guide to make sure you’re using the latest version and if needed download the latest version at https://zoom.us/support/download.

New Zoom Login URL

Additionally, please start using zoom.uga.edu to log in to Zoom if you are not doing so already. (Some of you currently log in at uga.zoom.us.)

Again, you might already be using the correct URL. But if not, please make sure to replace the old bookmark with the new one.

the zoom online meeting software's icon

Please contact us if you need help at oithelp@uga.edu.